What are the system requirements needed to use Babbel?

You can use Babbel on your smartphone, tablet, laptop, and desktop computer. Here are the system requirements needed for your different devices.

Desktop

You don’t need to install any special software to use Babbel on your laptop or desktop computer. Babbel runs on all modern computers with an updated internet browser.

On your laptop or desktop, you can access Babbel through www.babbel.com. If you’re using an older computer, check to see if you meet these requirements:

  • Operating system: either Windows 7 or above, or Mac OS X 10.12 or above
  • A recent version of Chrome, Firefox or Edge 

Download a compatible browser:

Note: We advise against using Babbel on Internet Explorer or Safari. Internet Explorer is an expired browser and will certainly lead to technical errors. Safari will not provide our users with the best learning experience. If you’re using one of these browsers, you’re more likely to experience issues with our speech recognition function

Mobile

To use Babbel on the go, you’ll need to download the Babbel app for your mobile device. We have both an iOS (Apple) and Android version of our app, which you can download here.

  • If you have an Apple iPhone or iPad, you’ll need to be running iOS 11.0 or above.
  • If you have an Android phone or tablet, you’ll need to be running Android 6.0 or above.

Note: The Babbel app may not be supported on rooted devices or on those with a custom ROM.

Was this article helpful?